Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Heedy

Pages: [1] 2
1
Add-Ons / Re: Blockland Glass 4.2
« on: April 11, 2018, 12:02:55 PM »
About the crash, it seems other people are having this issue as well?
https://forum.blockland.us/index.php?topic=312022.0
https://forum.blockland.us/index.php?topic=313658.msg9672989#msg9672989
https://forum.blockland.us/index.php?topic=316030.0
It happens with my custom gamemode, which executes a lot of files. It also happens regardless of whether or not I toggle the "Use BLG" in the start server menu. The issues goes away when I completely delete Blockland Glass. RTB and ORBs are not installed.

2
Add-Ons / Re: Blockland Glass 4.2
« on: April 11, 2018, 12:10:02 AM »
This thing crashes my server on startup whenever I have it installed. It's not even having it enabled; whenever it is even in my add-ons folder, it crashes my server. I can't diagnose it via console because it crashes at different intervals each time, and no glass errors are produced.

Also I don't know what this is but is it really needed every second?
https://i.imgur.com/hPfuwP5.gifv

3
Modification Help / Re: [Blender] New DTS plugin
« on: January 09, 2018, 05:16:54 PM »
The original post was a different model. I resolved it by just using 2.49 which works. I can't use 2.49 any more because the action editor lags like garbage and all of the visual artifacts from it generally just being outdated. I applied the modifier and I still get the error. When exporting selected objects only, the error only occurs when I have the "base" empty selected (probably because it's an animation export error).

4
Modification Help / Re: [Blender] New DTS plugin
« on: January 09, 2018, 01:51:54 AM »

5
Modification Help / Re: [Blender] New DTS plugin
« on: January 08, 2018, 10:24:25 PM »
I am getting this error when exporting.

This problem still persists. I have been using blender 1.49 because it;s generally still a lot better for DTS IMO, but it's getting to the point where it's starting to lag when animating and graphical artifacts and plaguing the UI.

6
Modification Help / Re: [Blender] New DTS plugin
« on: September 29, 2017, 01:03:04 AM »
I am getting this error when exporting.

7
Those are all on my wishlist. As you probably know, the last two both require support for bones, so that's the biggest thing. If I could support bones with similar feature parity I wouldn't even bother supporting bones, they're just a placeholder. I'd always like to work on bones, it's just a question of knowing how to do it.
Handling the overall structure is trivial, it's a question of getting actually correct data out of it (and whether or not it's even there), as Blender represents nodes entirely differently from Torque. I've had some ideas from time to time so it's not entirely out of the question, but it's nothing I can guarantee.
Understandable. If anything, I would love for the Action Editor to be included. Working with all the markers can get really messy with 40+ animations. If you have any tips from experience, please let me know.
Can you try with the latest version from the dev branch (including commit ffb6d07)?
I will try it out later.

8
Are you planning to soon work on:
  • Animating using bones instead of empties
  • Support for weight painting/vertex groups for bone influences
  • Ability to use actions instead of one long animation chain
If any of these are already possible, let me know. I don't want to waste time making a playertype using EMPTIES if bone support is coming (hopefully) soon. I'm stuck between using this and 2.49, but since 2.49 has similar opengl glitches that Blockland was having it makes using it almost impossible.

I also get this annoying error when trying to export "selected objects only". It occurs if you don't select all of the empties while exporting.

9
Drama / Re: StreamShark using speedhack
« on: January 02, 2016, 02:27:58 PM »
Would you like me to disrupt the server and flaunt it around? I try to not flaunt it around, or use it in a way that will disrupt the server. On your server, it was never disruptive until Amir started blabbering about it in chat.
The hell is this? I'm not buying any of it. It's entirely your fault for enabling and using that hack. You cannot cast yourself in a positive light. You willingly chose to enable and use a hack when you also could've just as easily chose not to. I don't care.
Personally, I don't think this should be a problem unless i'm majorly affecting servers, this drama is just saying I use it, nowhere have I been disruptive about it. So whats the problem with it? If what the BL community wants is me to admit it, then your job is done, I already have multiple times in this drama.
Blatant lie. You ARE majorly affecting servers. I was sent the video of you using it on dark's challenge server. On a server where players are supposed to set records by practicing and mastering various challenges, you just speedhack and set normally impossible records. This would be the very definition of disrupting the server and "flaunting" the hack (something you claim you try not to do).

This is what I mean when I say he blatantly lies about his use of the speedhack and tries to cast himself in a positive light. Do not believe any more of this bullstuff.

10
Drama / Re: StreamShark using speedhack
« on: January 02, 2016, 06:31:40 AM »
Please enlighten me and show me where I have denied speedhacking in this drama? The OP is complete bs as far as the steam chats, but of course no one wants to hear the truth and add me. If you are going to continue to debate this, atleast add me and not be completely one sided and act how CCA wants you to.
I said: "He's still using the speedhack and tries denying/excusing his use of it in-game.", which you do; You've done it at my server and others. You use the speedhack, and when people call you out, you dismiss it as a "meme" or make up an excuse about using a velocity boost or something. I wasn't at the server, but I was told by people on Dark x-rane's that you persistently denied using the speedhack, saying it was some kind of "velocity conservation" nonsense. I am sure Skill4Life can testify. I don't care about your greater-purpose bullstuff, the truth is that you cheat in game and then lie to the hosts about it, which is certainly grounds for a revoke.

11
Drama / Re: StreamShark using speedhack
« on: January 02, 2016, 04:06:30 AM »
noedit: hot damn this might be the most unexpected backfire of 2015
Holy stuff, drama just got backfired? Double time?
I don't understand how anything backfired here. If anything, there was an additional shot fired. Everything stated in the OP is still true, regardless of the additional context provided.
After finding out that none of that was true he decided to tell Cca to basically forget off and threatened "spreading the speedhack" to everyone in order to spite him (this obviously isn't happening, either).

Take it as you will but Stream isn't as bad a person as the conversation portrays.
Don't get distracted by this bullstuff. He's still using the speedhack and tries denying/excusing his use of it in-game. He should be revoked and the exploit should be patched.

12
Development / Re: 2015/12/12 - Blockland r1983
« on: December 22, 2015, 09:10:55 PM »
Since it's been a over a month since the runtime errors started occurring and there's been no visible progress (and no one has fixed it for him), does anyone have a link to the previous version? I want to host something for some friends for the holidays, but I don't want to keep resting every 10 minutes. If you don't want to post it here in fear of getting banned or whatever, could you PM me it?

13
Help / Re: C++ Runtime error
« on: December 13, 2015, 12:53:11 PM »
Are there any hosts out there who haven't gotten this runtime error? Not "Oh I hosted for an hour and didn't get it", i'm talking about people who host servers that are frequently populated with more than 15 players. If so, could you upload some basic info like maybe an add-ons list? Badspot seems to think it's caused by an add-on, so any proof for/against that would be nice.

In contrast, is there anyone who hosts a server that has gotten this error with only default add-ons?

14
Drama / Re: Zapk-Abusing slayer to crash servers
« on: December 12, 2015, 12:45:41 AM »
I normally would be against posting here, but I believe that this is a matter that actually effects the experience of people in game. Time and time again you see this stuff happen on this game, where certain users display a certain a balance between 'terrorizing' and 'philanthropizing' that everyone is quick to shame them when they do wrong, and then turn a blind eye and praise them when they do right. This is the problem here. I constantly see people like this being made admin, or being welcomed on a first name basis across multiple servers. People are quick to forget the major wrongs the instant someone does a minor right, going as far as buying keys for these users who have been revoked for deliberate for repeated instances of in-game abuse.

The term 'problem user' gets thrown around a lot, and normally I am against using the term, but the actual problem users aren't people who post annoying memes, or bait you on the forums, but the ones that cause trouble and ruin the game for the people who just want to play. People like this who weave their way into social circles, only to cause problems for everyone else and then retreat back to their safe haven where they're welcomed with open arms.

This guy has attempted numerous times to 'reform' and come back and the same suckers fall for it again and again. Stop believing that these people change, stop letting them play on your server, stop forgetting everything bad they did just because they made you a simple add-on.

From when he spammed the master server:
Quote from: Zapk (2014)
There is no better way I could have pulled the plug. I'm going to need to shut all of my stuff down anyway.

In response to the act being selfish and retarded, of course it is .. it's a suicide.
(http://forum.blockland.us/index.php?topic=265003.msg7791690#msg7791690)
Playing the fool:
http://forum.blockland.us/index.php?topic=265038.0
Eval exploit:
http://forum.blockland.us/index.php?topic=281892.0
It seems we have a recurring theme here:
Quote from: Xeidious*
Zapk and him were just discussing what the cause and fix of this could be, let's not just to the conclusion that it was zapk YET, yes he's been known to do this. But i don't believe it was him doing all the spam this time. the exploit was posted apparently so people are taking advantage of it.
(http://forum.blockland.us/index.php?topic=281597.msg8434758#msg8434758)
This was just a simple one page google search, I'm sure there are many more topics/posts you can find, as well as addition anecdotes from users in this very thread. But people tend to forget these things because he's "changed" or he hosts a popular server or released a cool add-on.
http://forum.blockland.us/index.php?topic=265084.0 (This one was not even a DAY later than when he hijacked pecon's site)
http://forum.blockland.us/index.php?topic=265098.0
http://forum.blockland.us/index.php?topic=288889.0
http://forum.blockland.us/index.php?topic=288876.0

It's entirely his fault for choosing to exploit/crash servers, but welcoming him back into your social circles definitely doesn't help curb the problem.

15
Development / Re: 2015/12/10 - Blockland r1981
« on: December 10, 2015, 11:16:45 PM »
In order to fix a problem, I have to be able to duplicate it or at least be given some clue as to where or when it occurs. 
People have posted information in the last update's topic.
Quote
Can you tell us if any of this information is helpful at all? Multiple people have reported the same circumstances for which the error occurs (player loading), and someone even provided a potential lead for the function itself.
Quote from: Val
Zeblote sent me a picture of what the stack looks like when the game crashes with the pure virtual call error. It seems to occur in octTree::castRay_r, and the call to the only virtual function referenced calls on an item from a big container (seems to be octTree::smServerTree)

Maybe it calls on an object in the tree (with the type being an abstract base class) that hasn't quite initialized yet?
You have to say whether or not any of this information is helpful or not, or provide tools to help us debug it. I'm not sure what more 'clues' we can really give without any response as to whether or not they're helpful.

Pages: [1] 2