Author Topic: PSA: Unchecking "Disable VSync" fixes the Win10 mouse glitch  (Read 3272 times)

Added PSA if this doesn't fix it: Go to your desktop, right click, go to display settings and put the scaling to 100% if it isn't already.

Bumping. This has been an issue for me, when vsync is on i'm locked to 30FPS which is bullstuff (used to avg 200+) and even if I uncheck it I only get 57. I get the mouse glitch either way, although it is worse when vsync is off.

Has there been any other solutions to this?

Mine has been at 100% and i'm always doing unintended 360s lmao

unchecked vsync, we'll find out!
« Last Edit: January 30, 2018, 07:55:54 PM by IdeTheBird »

damn, i had no clue it was an OS problem
i went through two new mice already and a couple hours of driver/software research in my troubleshooting efforts :<

damn, i had no clue it was an OS problem
i went through two new mice already and a couple hours of driver/software research in my troubleshooting efforts :<
It's a total pain in the ass.

Bumping. This has been an issue for me, when vsync is on i'm locked to 30FPS which is bullstuff (used to avg 200+) and even if I uncheck it I only get 57. I get the mouse glitch either way, although it is worse when vsync is off.

Has there been any other solutions to this?
VSync is based on your graphics card and monitor, usually it locks up to 60fps so some requirements fail to achieve

I haven't had any problems, guess i'm one of the lucky ones
Didn't even know there was a bug, so must be the same

It happens when you upgrade to "Creators" or "Anniversary" update (sometimes you don't know if you did upgrade or not) for Windows 10, I haven't seen the issue on other platforms

It happens when you upgrade to "Creators" or "Anniversary" update (sometimes you don't know if you did upgrade or not) for Windows 10, I haven't seen the issue on other platforms
Well I have the Anniversary update because to play Forza it forced me to. Does anyone have a solution to this? I have vsync on and everything and it doesn't do anything. My game is becoming unplayable.

Edit: So this is the weirdest thing, but I enabled shaders and the problem disappeared.. could be a total coincidence but figured i'd note it. If it changes i'll post an update.

Still looking for solutions that don't involve keeping shaders on.

Edit 2: It was a coincidence.
« Last Edit: February 01, 2018, 02:45:57 AM by Clear Glass »