Author Topic: Has anyone ever had random disconnects from some servers for missing models?  (Read 1077 times)

For some reason my server seems to be the most problematic with random model issues (randomizer), but the weirdest part is that this doesn't happen at all on another server I have (a dev server) that also has a lot of add-ons enabled but hosted in a different folder location. Some people disconnect from weird models such as missing the default gun model to the original player model, and a lot of times people connect and spawn without a problem. I've been trying to debug and figure this out but I still have no idea on what's causing this issue. I've tried some methods such as resetting the cache and running the updater to see if something is weirdly going on. It's like a gamble because it doesn't always happen.

Does anyone have an idea or also experience this on some servers (or all servers)?

yeah, this used to happen to me with pomps tank pack all the time

I've experienced this on many servers.  It's usually a server with some custom playertypes.

Personally I think it might have something to do with animation name string length.  There's an issue w/this where the combined string length of an object's named animations will be too long, and some of the animations will not work.  Afaik people in Blockland have been getting around this problem by assembling the shapes w/dsqs.  The animations will work, but, I guess it causes network issues w/trying to send too much info in a single packet?
That really is just my theory.

I ran into this problem while trying to make an animated 4 slot counter(4*10*2 animations).  I opted to simplify the animation names and reduce the number of them, instead of trying to do any tricks with dsqs.



Oh! I also encountered this when modifying default datablocks.  I was trying to change the order of datablocks so that an add-on's 1x5 would show up between the default 1x4 and 1x6.  But this created a consistent error spouting some nonsense about a missing m.dts
« Last Edit: May 07, 2018, 01:34:25 PM by Tendon »

This topic talked about the missing sequence issue and found it was caused by overflowing the packet buffers in a certain way. To briefly sum it up, it only happens when a large amount of bytes are already written to a buffer where another chunk of ~500 bytes will cause an overflow on the 1024 size limit and 1500 absolute limit. When this happens, any remaining data can't be sent and will cause a crash since it's a malformed packet.

You describe your problem vaguely but I am certain the cause for it is similar to what was discussed in that thread. So, the only fix to this is to wait for someone to do it in a DLL or let Badspot deal with it.

I'm pretty sure that is the cause (overflow) because this didn't happen for a long time, and ever since I transferred to another VPS the problem started (bl exe wasn't successfully moved over).

yeah, this used to happen to me with pomps tank pack all the time
still happens to me with pomp's anime playertype


see the issue is that your using an anime playertype mod

happens to me all of the time

i still cant join crowns jailbreak