Author Topic: [Solved] Fix for Item_Score_Pickups and Player_L4DSurvivor  (Read 951 times)

So, there's two add-ons I want to use together. But whenever I try to pickup the score items, they don't work with the playertype. I know the L4D Survivor playertype has customization to edit what items can be picked up for each category, but that still doesn't work neither? Here's the two add-ons, and I have a console log. These add-ons don't work correctly even with every other add-on besides those two enabled.

Item_Score_Pickups (RTB)
Player_L4DSurvivor (RTB)

I had trace enabled when testing the two add-ons in the console log, just for those wondering.

« Last Edit: January 18, 2019, 05:16:43 PM by Spartan224 »

Thanks Revive, I tried to do some testing with the setting the coin item on a brick and making an event for it to spawn when activated, but the same issue regardless with your fix.

EDIT: I also edited the .txt files that determine which items are going to be used for each slot, and enabled the Coin(Copper) item in every .txt file, but still the same issue.
Provided a new console log with trace enabled as well.
« Last Edit: January 18, 2019, 11:10:49 AM by Spartan224 »

I looked at my file again and realised I should be ashamed for posting such a terrible fix. I got it to kinda work now, but the problem is whenever I pick up the coin/gem I get both the points and an empty item (a white printgun with no name). If you want to take a look at the code yourself, I would recommend you to take a look at Support_L4DItems.cs in the Player_L4DSurvivor addon. Look for the function Player::pickup(%player,%item);

I'll continue to take a look at it, but I'm not sure if I'm able to get it fixed.

Huh, well darn. If there's no simple way to fix this then I may have to look for an alternative.

I think I fixed it now:

Just keep in mind those coins and gems should not be in the .txt files.
Output events like addItem doesn't work neither, but thats how it works for all playertypes.

Sounds good dude, I'll be testing it right now.

Alright, I just tested it right now and it works great. Although this last part isn't much of an issue, but the message that I already have a primary weapon pops up when I pick up the coin. This is my last problem. This last fix is optional, and I'll be fine from there. I appreciate your help.
« Last Edit: January 18, 2019, 05:01:14 PM by Spartan224 »

Ye, now it works correctly. Thanks man, now I can use these two great add-ons. Locking thread.