Author Topic: 2012/12/17 - Blockland r1775  (Read 38077 times)


got this image while ghosting

Where the forget did the last bit go?
It caused errors to only some people.

-snip-
got this image while ghosting

Do this into your console
Code: [Select]
flushtexturecache(); and see if that helps. It worked for me when I had that error.


Security issue with fileobjects, errors from rtb due to file objects, and openforappend not working?
What's going on?

We need a snowball fight server.


What was the file exploit?

Will you change the max packet size?

« Last Edit: December 18, 2012, 03:46:12 PM by Trogtor »


Found a glitch, when throwing a snowball while sitting, the snowball will go backward and very high

Edit: in 3rd person only
Not a glitch, all weapons are affected by the use of thirdperson if they're told to fire from the eye

Like sitting and crouching with a gun and firing it while in thirdperson will make it fire directly into the sky

Code: [Select]
ERROR: FileObject::writeLine - file is not open
BackTrace: ->RTBCC_Socket::onLine->XMLParser::bufferData->XMLParser::parseBuffer->XMLParser::throwCallbacks->RTBCC_Socket::onNoticePacket->RTBCC_RoomSession::onNotice->RTBCC_RoomSession::writeNotice->RTBCC_RoomSession::log
ERROR: FileObject::writeLine - file is not open
BackTrace: ->RTBCC_Session::send->RTBCC_Session::writeMessage->RTBCC_Session::log
This stuff is new. What did you do to the file objects?
I get the same error.


Problem with fileObjects:

fileObject::openForAppend(%file) does not work properly. A new file is created but whenever you attempt to write lines to it you receive an error that the file has not been opened:
Quote
ERROR: FileObject::writeLine - file is not open

Try it yourself:
Code: [Select]
new fileObject(test);test.openForAppend("base/TEST.txt");test.writeLine("Hello World");test.close();test.delete();
Update: FileObject::openForWrite appears to work correctly.

For any of you who want to spawn a snowball from a brick or whatever, I made an add-on for that.