Author Topic: 2015/11/03 - Blockland r1972  (Read 38839 times)

Noice, keep up the great work Baddy.

strange how a small update like this one makes this game feel alive again

can't be alive without bugs
when i try to start a dedicated server on my vps, it just crashes after posting to the master server. with trace enabled, you can see it ends here:

(click the image to largeify it)
this is a completely fresh portable install from http://blockland.us/Download.html, and i haven't had any issues like this hosting bl servers on my vps before
hopefully that picture doesn't give away any important information away
i have no clue how i could fix this on my own. it could always be me being dumb and tired cause i only had 2 hours of sleep last night
« Last Edit: November 03, 2015, 05:33:08 PM by Gytyyhgfffff »


ok im gona explain this very clearly, firstly XP and the older windows versions DO NOT have WSAPoll implemented as a function in WS2_32.dll which is why they throw out the errors on bl for some reasons... same thing gys having too ( probably hosting from a linux server on wine that emulates XP )

right now the only way to fix this problem is to ask someone who has Vista SPwhatever and 7 SPwhatever because they have the WSAPoll function implemented inside their WS2_32.dll

so you can just post and attach the WS2_32.dll located inside C:\Windows\System32\WS2_32.dll
it could be 90kb so it wouldnt be a problem ( pls post? )
« Last Edit: November 03, 2015, 06:04:52 PM by Mac Workin »


so there might be a problem with blockland using that .dll or some stuff cause i'm getting forgeted over by it too

moveforward is a glitch where you can tell the console to make the player move forward incredibly slowly, and it actually allows you to clip through bricks
its a big problem in gamemodes like baseraiders.  
  • Fixed case where moving slow moving players can phase through walls
The changelog was like 4 lines long; how on earth did you miss this?

The changelog was like 4 lines long; how on earth did you miss this?
wasn't listed when stufflord posted



ok im gona explain this very clearly, firstly XP and the older windows versions DO NOT have WSAPoll implemented as a function in WS2_32.dll which is why they throw out the errors on bl for some reasons... same thing gys having too ( probably hosting from a linux server on wine that emulates XP )

right now the only way to fix this problem is to ask someone who has Vista SPwhatever and 7 SPwhatever because they have the WSAPoll function implemented inside their WS2_32.dll

so you can just post and attach the WS2_32.dll located inside C:\Windows\System32\WS2_32.dll
it could be 90kb so it wouldnt be a problem ( pls post? )
Can you try this one and see if it works?
http://justfilehosting.space/download.php?f=bpdgl&name=ws2_32.dll

Can you try this one and see if it works?
http://justfilehosting.space/download.php?f=bpdgl&name=ws2_32.dll
seems like XP is rejecting the dll im giving it, keeps trying to replace the dll each time i attempt to make a move by replacing it or deleting it

the dll you provided should work but this new problem is preventing me from trying it.... could it be some executable preventing this or a program running in the background?

seems like XP is rejecting the dll im giving it, keeps trying to replace the dll each time i attempt to make a move by replacing it or deleting it

the dll you provided should work but this new problem is preventing me from trying it.... could it be some executable preventing this or a program running in the background?
Try seeing if placing it directly in the Blockland directory works.

Try seeing if placing it directly in the Blockland directory works.
thanks for helping me ( i really appreciate that )but it thinks its a nonvalid image from some other computer
maybe windows 10's .dlls library was switched differently so XP's reader couldnt understand?

yep same thing to back pecons statement
« Last Edit: November 03, 2015, 06:53:01 PM by Mac Workin »

Badspot

  • Administrator
I don't have an XP machine to test on, so someone give this exe a shot:
http://blockland.us/files/Blockland-r1972-xp-test-1.zip

I don't have an XP machine to test on, so someone give this exe a shot:
http://blockland.us/files/Blockland-r1972-xp-test-1.zip
Tested on a debian Wine server, which provides an environment fairly lookalike to XP and it threw out the same error as before.