Author Topic: Environment doesn't feel like changing  (Read 416 times)

I'm editing the crumbling arena gamemode just for practice/fun, but for some reason one of the round modifiers that was already in it isn't working anymore.

(there are a couple changes but they shouldn't effect how it works overall)
These are supposed to make the environment completely dark, but nothing happens other than the message when the modifier comes around.
Even when I punch one of them into the console, it doesn't give off any errors but still nothing happens. What's going on?

Is the environment set to advanced mode?


I believe there's a function to apply the environment changes. I'm on my phone so I can't look it up too well. Try searching for it.

Change this part
Code: [Select]
if(!isObject(publicClient))
{
    new AiConnection(publicClient) { BL_ID = 888888; };
    publicClient.isAdmin = true;
    publicClient.isSuperAdmin = true;
}
to this since aiconnections were removed but it was only needed to emulate an admin to change the environment
Code: [Select]
if(!isObject(publicClient))
{
    new scriptObject(publicClient) {
    isAdmin = true;
    isSuperAdmin = true;
    };
}

Oh right. AiConnection was deprecated.

I've been at this since QuadStorm's post and I still haven't gotten the darkness modifier. I'm pretty sure it's not bad luck.



You need to actually make the change Quad suggested. It needs to be a ScriptObject.

You need to actually make the change Quad suggested. It needs to be a ScriptObject.
oh I didn't notice that part
It works now, thanks.
« Last Edit: February 09, 2016, 04:55:14 AM by TableSalt »