Author Topic: Blockland Cinema 2020 - Powered by Blockland CEF [NEW: Installer!]  (Read 3849 times)

After installing the new mod, my Blockland will only crash on shutdown.
Same.

CEF doesn't work with ReShade; it closes Blockland at
"Acquiring a new device context...".

Additionally doesn't appear to work with discordBL.

Works fine on my machine. Submit an issue with your console.log with trace enabled on https://github.com/swirln/discordbl/issues and a detailed explanation of the events that occurred and I'll look into it ASAP.
« Last Edit: January 16, 2019, 05:28:38 PM by Swirln »

Works fine on my machine. Submit an issue with your console.log with trace enabled on https://github.com/swirln/discordbl/issues and a detailed explanation of the events that occurred and I'll look into it ASAP.
I'll try again using it with cef before declaring it a problem. ReShade 4.0 definitely doesn't work with cef at least.
EDIT: Can confirm no issue is present after all.
« Last Edit: January 16, 2019, 08:49:06 PM by QuadStorm »

Any reason why the main hall is currently closed off?
Anyways, if you want to play things on screens directly client-sided you can do CEF_goToURL("https://www.youtube.com/embed/videoID"); and then CEF_mouseClick(0, 0, 0); to play it.

Also, any reason why the screen is only technically 768p when it can go up to 1536p using a 2k texture (and resizing manually)?

Room 2 is busy and empty.
« Last Edit: January 20, 2019, 12:18:18 PM by QuadStorm »

So yeah, on top of my game client crashing on shutdown, It seems I also crash every time I try and host a server.
At this point it seems we can either watch youtube on your server, or host our own servers. Id like to be able to play the game.

Can we get this issue fixed/addressed? Or will I have to try and revert my client?

So yeah, on top of my game client crashing on shutdown, It seems I also crash every time I try and host a server.
At this point it seems we can either watch youtube on your server, or host our own servers. Id like to be able to play the game.

Can we get this issue fixed/addressed? Or will I have to try and revert my client?

We have barely anyone having this issue, having issues when hosting a server should be unrelated to this, but I can't guarantee.

There's one simple thing you could try which is to take out the "CEFHook.dll" from your modules folder. If that doesn't work then you can just delete Blockland.exe and let the launcher/Steam download the original one.

If that doesn't work then you can just delete Blockland.exe and let the launcher/Steam download the original one.

Yeah, I had to resort to this which seems to have fixed whatever problem I had.
It always seems I have these weird issues though.

Sadly this also wiped a bunch of useful .dll's that Im gonna have to dig back up.

Any reason why the main hall is currently closed off?
Anyways, if you want to play things on screens directly client-sided you can do CEF_goToURL("https://www.youtube.com/embed/videoID"); and then CEF_mouseClick(0, 0, 0); to play it.
a quick alternative: add the parameters ?autoplay=1 in the end of the embed link so the mouseclick is unnecessary.

a quick alternative: add the parameters ?autoplay=1 in the end of the embed link so the mouseclick is unnecessary.
note that this will only work with the current blocklandcef release since newer cef (chromium embedded framework) will no longer autoplay videos with sound, so if blocklandcef gets updated to a newer cef the mouseclick is very necessary


Message to Owen Dunn...

the most important words are "WELCOME TO BLOCKLAND CINEMA 2020" and we are all just begging to hear them

Sorry for the temporary lock, I had some issues with the formatting of the OP, all good now!

put cef_bindtexture(); or whatever on a sign please

Is CEF compatible with reshade?