Author Topic: Blockland can't load save, only loads bricks on the ground  (Read 108 times)

I was hosting a server, and I went to load in the save that I use. When I spawn the save, it only loads the 2 bricks touching the ground. I can't fix it and there's no ding sound effect to signify that all bricks have loaded, so it cant be ghosting. I tried loading bigger and smaller saves, and it didnt work. The only thing i can note is that i was using a different colourset when i last loaded it, and thats when it worked.

i think i can help you i just need your console log

i think i can help you i just need your console log

Sorry for being late but, heres my console.log.

At the bottom is where the error occurs.

looks like an issue with the save file
ERROR: ServerLoadSaveFile_Tick() - Bad line "" -34.5 -6.25 1.4 3 0 50  0 0 1 1 1" - expected brick line but found no uiname
if you remove the issue in the file, it will probably load the rest of the bricks

How can I remove the issue in the file?

easy fix is to delete the line that contains "" -34.5 -6.25 1.4 3 0 50  0 0 1 1 1" but it can potentially forget with the file

select it with the mouse or using shift + arrow keys
then press either delete or backspace

if you post the file somebody else might be able to do it for you

Alright, i will try to do this. I will back up the save just to be sure.

So I took your advice and did the following.

I cloned and opened the save file with NPP (notepad plus), looked for the line and deleted it. I opened blockland, loaded the save, and it actually works!
Thank you so much for this, I'm able to host my server now because of this.