Author Topic: Can't load my map  (Read 1033 times)

I was working on a map yesterday and it all seemed to be working fine and I took a break and loaded the map again and it worked fine (in the past when I've closed the map and re-opened it hasn't worked) so I thought my map was completely fine. However today I tried opening the map and I'm having no luck what so ever. I've loaded the map from the admin map menu, and it just pauses on mission loading screen. I've loaded Flatlands then in mission editor tried opening mission and I've had the same results

I'm new to map making so I really don't have a clue on what to do, here is my console file hopefully one of you might see the problem.

Code: [Select]
*** LOADING MISSION: Add-Ons/Map_A_Tropical_Forrest/TropicalForest.mis
*** Stage 1 load
Mission Name: Tropical Forest
Mission SaveName: Tropical Forest
Mission Description:
*** Stage 2 load
Executing Add-Ons/Map_A_Tropical_Forrest/TropicalForest.mis.
Add-Ons/Map_A_Tropical_Forrest/TropicalForest.mis Line: 80 - Syntax error.
>>> Some error context, with ## on sides of error halt:
         indoorWeight = "1";

         outdoorWeight = "1";



   new ScriptObject(ClientGameModeStorerSO) {

         modeRuleDef0_1 = "0";

         modeRuleDef1_2 = "0";

         modeRuleDef3_5 = "16";

         modeRuleDef4_3 = "1";

         modeRuleStr-1##_##0 = "bool";

         modeRuleTxt-1_1 = "Allow Dead Talking";

         modeRuleDef0_0 = "0";

         modeRuleDef1_1 = "0";

         modeRuleDef3_4 = "0";

         modeRuleDef4_2 = "30";

         modeUsesTeams0 = "0";

         modeRuleCount0 = "3";

         modeRuleDef1_0 = "0";
>>> Error report complete.

No 'MissionGroup' found in mission "".
BackTrace: ->SM_StartMission->createServer->loadMission->loadMissionStage2

Got connect request from IPX:00000000:000000000000:0
  lan name = Hoogle
Connection established
Connected successfully, killing other pending connections
AUTHCHECK: Hoogle = LAN client -> LAN server, loading
CADD: 10906 local
 +- bl_id = 999999
 +- no auto admin

base/server/mainServer.cs (405): Unable to find object: 'mainBrickGroup' attempting to call function 'add'
BackTrace: ->SM_StartMission->GameConnection::onConnect->GameConnection::authCheck->GameConnection::startLoad

De-activating package: AmmoGuns
Activating package: AmmoGuns2
Activating package: AutoApplyEvents
Activating package: StoredVariable
Activating package: VCE_Main

BackTrace: ->[chatLogger]secureClientCmd_ClientJoin

looks like you have a bunch of extra junk in your map.

When you work on maps, make sure you are in single player mode, and with irc shut OFF.
its also best to have ZERO addons active.

open your .mis file in notepad and remove all the ScriptObject stuff  -- except for the map description at the top.

Thanks, I got rid of the stuff about the Game_modes (dunno why that was there) and I deleted all the trees and it worked.