Author Topic: 2011/10/12 - Blockland Launcher r1361  (Read 44877 times)

Badspot

  • Administrator
If you are having trouble running Blockland, here is a new version of the launcher for you to try:

Windows:
http://Blockland.us/files/Blockland_Setup_r1361.exe

Macintosh:
http://Blockland.us/files/Blockland_OSX_r1361.dmg
http://Blockland.us/files/Blockland_OSX_r1361.zip

  • Fixed -profilePath option being applied after console.log was already open
  • On Mac, launcher will attempt to make profile path writable
  • Improved error logging
  • Fixed compatibility problem with OSX 10.5.8
  • Fixed quote handling when setting -profilePath
  • Fixed handling high-ascii characters in profile paths (characters like , , etc)


If you were having a problem before and this works, please post.  

If you are still having a problem, please describe the problem and post your launcher.log file found in My Documents\Blockland (windows) or /Users/yourusername/Documents/Blockland (macintosh)

If you have never had problems do not post.
If you don't know what you're talking about do not attempt to "help" people.

« Last Edit: December 17, 2011, 06:02:22 PM by Badspot »


I'm trying it out now, I'll see if it works for me. Thanks for the patch/update.

EDIT: Yes, this appears to fix all the problems I was having, thank you.
« Last Edit: October 10, 2011, 10:29:51 PM by pecon98 »

I'm not sure what's going on but Its been bothering me.


« Last Edit: October 10, 2011, 11:47:17 PM by Riot »

This Fixed My Problem with it not actually running blockland.exe, thanks much!

I'm not sure what's going on but Its been bothering me.


Do you have a computer that is newer than a G5?

interesting, i thought people were only having problems with getting the updater to go, not problems with the updater itself
for some reason the updater wasn't automatic for me and so i used clientcmd(doupdates);, which works fine i guess

Do you have a computer that is newer than a G5?

I knew this would be the concern. I'll just hang back and catch up on other things until I get a new compy.

interesting, i thought people were only having problems with getting the updater to go, not problems with the updater itself
for some reason the updater wasn't automatic for me and so i used clientcmd(doupdates);, which works fine i guess

Please download and run the launcher linked at the top of this thread.

I knew this would be the concern. I'll just hang back and catch up on other things until I get a new compy.

It could be another cause. Are there are any other G5 users out there? Does the launcher work for you? Note that Apple has finally dropped support for G5s in 10.6, so you probably want to update anyway.

Once again, I'm getting the exact same error, I really do hope that the problem isn't that I have a mac os x 10.5

Once again, I'm getting the exact same error, I really do hope that the problem isn't that I have a mac os x 10.5

Mac OS X 10.5 should work just fine. PPC systems (with a G5 chip) might have problems. Anyway we have a new launcher coming soon that ought to fix the problem.

Update: 1352 is out, that is the update I was talking about, please try it.
« Last Edit: October 11, 2011, 03:10:54 AM by kompressor »

Badspot

  • Administrator
Once again, I'm getting the exact same error, I really do hope that the problem isn't that I have a mac os x 10.5

Try this:
http://Blockland.us/files/Blockland_OSX_r1352.dmg
http://Blockland.us/files/Blockland_OSX_r1352.zip

I'll try it on my Mac G4/G5 (it has 10.4.11 tiger and that's all I know).

BlocklandLauncher.exe worked well for me but, Blockland.exe is now halting at
OpenAL Driver Init
OpenAL
%

What's wrong with it? It doesn't continue.