Author Topic: 2012/09/05 - Blockland r1728  (Read 38682 times)

Badspot

  • Administrator
Primary changes:

  • Separated minimum shader into its own file with reduced requirements.  More people should be able to run minimum shaders now.
  • If you do not meet the minimum requirements for a particular shader level, that option will be disabled in the gui. 
  • Fixed ~1400 compilation warnings related to the torque engine.  This shouldn't effect anything in game but I changed a huge number of lines of code so don't flip out if soPhysician Prescribed Desoxyning is broken.


Additional changes:

  • Fixed "/Users/erichartman/dev/Blockland/premake/BlocklandGame/../../engine/bricks/octShadows.cpp:620 - GL Error: 1280 - GL_INVALID_ENUM" error spam
  • Fixed screenshots saving with wrong extension
  • Fixed potential console error from fxDTSBrick::sendWrenchSoundData
  • Fixed self-illuminating textures under shaders
  • Fixed shadow artifacts occuring when you travel more than a certain distance from spawn
  • Fixed errors related to attempting to asign music datablock with a null filename to a music brick
  • Raytraced preview image (the images that show up here) now take sun angle, lighting conditions into consideration. 
  • Raytraced preview image now scales to fit entire scene
  • Raytraced preview image now shows ground and water planes
  • Improved raytracer performance
  • Fixed console errors related to unescaped 's in welcome message (for real this time)
  • Calling strPos with empty arguments now always returns -1
  • Added check for infinite recursion of onWindowReactivate
  • Fixed corruption from wav files with truncated smpl header (caused servers running certain add-ons to become unjoinable)
  • Fixed setKey() function not working from dedicated server console
  • Added additional check for air control, may fix problem of air control mysteriously failing
  • Fixed temp brick disappearing whenever you pull out a tool if random brick color is enabled
  • Fixed advanced settings not applying if you update them in-game using the gamemode dialog

Woah! Thanks Baddy!
Although, I cannot run them on medium (I read it in the OP):



Oh, and here is them on low! Beautiful!



Stop re-editing your post with your giant loving screenshots -- Badspot
Thanks for fixing the image size, Badspot.
« Last Edit: September 05, 2012, 03:32:25 PM by Dr_Zegobob »

Badspot

  • Administrator
Woah! Thanks Baddy!
Although, I cannot run them on medium:
http://i.imgur.com/qbRwu.jpg

Can you run them on low or minimum?  Post console.log of you attempting to set them to medium.

Oh yes, Thanks baddy!

Ill post my new results in a few minutes

thanks for fixing macs :) though I get this weird error at anything not minimum
Low

Let me take a few more
Medium

High


Good work btw
« Last Edit: September 05, 2012, 02:21:00 PM by Brian Smithers »

Good work! But can you fix it so when you try to delete the standard screenshots it doesn't keep downloading them?

Badspot

  • Administrator
Good work! But can you fix it so when you try to delete the standard screenshots it doesn't keep downloading them?
No.

Good work! But can you fix it so when you try to delete the standard screenshots it doesn't keep downloading them?
Glad I excluded screenshots from my custom launcher :cookieMonster:

Medium


Good work btw
Dude that's a secret code!
We must decrypt it and find the golden brick!

Thanks baddy, I'll post my results in a minute

Can you run them on low or minimum?  Post console.log of you attempting to set them to medium.
I edited my post about running them on low. Works perfectly.
Also, console.log after running them on low and medium:
Quote
Dr. Zegobob spawned.

Checking for shader shadow support:
   - Enabled via $Shader::Enabled? YES
   - ARB_shader_objects?           YES
   - ARB_shading_language_100?     YES
   - EXT_texture_array?            YES
   - EXT_texture3D?                NO
   - glTexImage3D?                 YES
   - EXT_framebuffer_object?       YES
   - ARB_shadow?                   YES
   - OpenGL Version?               2.1 NVIDIA-1.6.40
   - GLSL Language Version?        1.20
   o Shaders are                   ACTIVE

/Users/erichartman/dev/Blockland/premake/BlocklandGame/../../engine/bricks/octShadows.cpp:176 - GL Error: 1281 - GL_INVALID_VALUE
Regenerating Shadow Map FBOs...
Creating shader program from shaders/Minimum_vert.glsl and shaders/Minimum_frag.glsl...
Creating GLSL program...
Attaching shaders...
Linking GLSL program...
WARNING: vertex shader writes varying 'vPos' which is not active.

optionsDlg::setShaderQuality reloading shaders...

Checking for shader shadow support:
   - Enabled via $Shader::Enabled? YES
   - ARB_shader_objects?           YES
   - ARB_shading_language_100?     YES
   - EXT_texture_array?            YES
   - EXT_texture3D?                NO
   - glTexImage3D?                 YES
   - EXT_framebuffer_object?       YES
   - ARB_shadow?                   YES
   - OpenGL Version?               2.1 NVIDIA-1.6.40
   - GLSL Language Version?        1.20
   o Shaders are                   ACTIVE

Regenerating Shadow Map FBOs...
Creating shader program from shaders/renderCsm_vert.glsl and shaders/renderCsm_frag.glsl...
Creating GLSL program...
Attaching shaders...
Linking GLSL program...
Regenerating Shadow Map FBOs...
Executing config/server/prefs.cs.
optionsDlg::setShaderQuality reloading shaders...

Checking for shader shadow support:
   - Enabled via $Shader::Enabled? YES
   - ARB_shader_objects?           YES
   - ARB_shading_language_100?     YES
   - EXT_texture_array?            YES
   - EXT_texture3D?                NO
   - glTexImage3D?                 YES
   - EXT_framebuffer_object?       YES
   - ARB_shadow?                   YES
   - OpenGL Version?               2.1 NVIDIA-1.6.40
   - GLSL Language Version?        1.20
   o Shaders are                   ACTIVE

Regenerating Shadow Map FBOs...
Creating shader program from shaders/renderCsm_vert.glsl and shaders/renderCsm_frag.glsl...
Creating GLSL program...
Attaching shaders...
Linking GLSL program...
Regenerating Shadow Map FBOs...


Everything works, thanks, good job!


Well, the console spam is gone, and I think it's running better, but I'm still having issues.

Without anything loaded, on Max


With a build loaded, on Max


With a build loaded, on Max (from above)


Console.Log
http://sdrv.ms/NdapUQ

Thank you, Badspot, for working so hard to fix this!
-Gibson
« Last Edit: September 05, 2012, 02:39:09 PM by Supersolider »