Author Topic: 2015/11/03 - Blockland r1972  (Read 52024 times)

Anybody know what is causing it? Is it oRBs?

Considering oRBs is just another revival of RTB, it more than likely contains the same code that's crashing the game.

I would take a gif to show you but i guarantee you i know what i'm talking about. You type moveforward(0.1); into the console and then position yourself perpendicular with the brick, and you go through it.
okay, I see
but I don't think it was unreasonable for me to think that, I mean look at it

Those getting the pure virtual call error should report the address where it happens (this can be done with a debugger like ollydbg)

Anybody know what is causing it? Is it oRBs?

I am not getting any crashes or pref issues with orbs.
Perhaps a specific add-on?

Those getting the pure virtual call error should report the address where it happens (this can be done with a debugger like ollydbg)
Does it need to be attached all the time or can I do that when a crash happens?

Now that I'm thinking about it, both crashes happened while someone was loading.
« Last Edit: November 06, 2015, 02:10:39 AM by Zeblote »

not sure if anyone thought about this but could all the linux crashing have to do with the fact that wine is set up to be default windows XP?
you change to 7 or 8 in the settings

I sent you a PM about the packet rate while ghosting

I am not getting any crashes or pref issues with orbs.
Perhaps a specific add-on?
Yup, it still crashes after an hour or so without oRBs.
« Last Edit: November 06, 2015, 01:23:50 PM by Wesley Williams »

Mine is crashing as soon as the Blockland Client logs in.

EDIT: Never mind, the problem was Blockland Glass was interfering with the new update.

http://forum.blockland.us/index.php?topic=287834.0
« Last Edit: November 06, 2015, 07:44:59 PM by halonerfer29 »

Blockland doesn't seem to like the higher packet rate on many servers. It'll look like this:



I can imagine two causes for this:

1) Too many packets at once, the server doesn't have enough upload to send all of them so many get lost. It takes a long time to re-send them, only to have most of them lost again. Could be fixed by lowering packet rate if over 10% are dropped.

2) Packets arrive unordered and get dropped.


Still getting stuck downloads after this update seems to be related to this. On servers with high packet loss (like above) the download will often freeze for multiple seconds while the client is waiting for the correct packet. It doesn't actually break, if you wait 10-20 seconds it will continue.
« Last Edit: November 09, 2015, 02:30:44 PM by Zeblote »

  • Fixed certain cases of file downloads stopping
Joy to the world.

Do you think the issue with the Mac version of the game on Steam not being able to write will be solved soon?

Do you think the issue with the Mac version of the game on Steam not being able to write will be solved soon?
Is there a fix incoming for OS X Steam version file creation? When you try to create folders for new files, the folders get created in the OS root folder (/) and the files are never created, instead you are thrown an error.
pageloss

ok there's a big issue with images that i've just figured out
lights on images don't work at all on dedicated servers
for example, the crown victoria vehicle has lights on it, and the lights use images. if you look at the crown victoria's lights in a dedicated server, you will never see them for whatever reason. it might not work in non-dedicated servers either, i have no clue honestly. it definitely works singleplayer though.
i've also encountered this issue myself before when i was working on a project but i didn't actually realize it was this very bug
this is a pretty big issue in my eyes so it would be nice to see that fixed

  • Fixed missing admin checks on some bot_hole server commands
  • Fixed case where moving slow moving players can phase through walls
Heh.