Author Topic: "Server Could Not Verify Your Blockland ID"  (Read 294 times)

Having a weird issue where I can't join any servers, with the error message listed above. I've tried restarting the game and also re-entering my key, no luck.

I've attached a console log below.

Any ideas?



I do not believe that's the case.
Forgot to mention this in my post; if you have an invalid or revoked key, you'll get an auth failure right on the main menu. That's not what is happening for me, so it cannot be that. Did you view the console log?

Its definitely not a revoked key, they're just being dumb. This usually happens often if you use the steam version of blockland if steam goes offline but for non steam I think its just not connecting to the master server properly. My best guess to solve it is just restart blockland, if nothing changes just wait a while I suppose. I don't get issues like this ever.

People have run into this for years and I still don't think there's a sure fix, but Badspot has given some advice

No, if your key is revoked then authentication will fail on the main menu.  It won't ever say "Welcome, <your name>"



The cause of this is most likely that your UDP and TCP traffic are being routed differently.  So you end up authenticating with one IP address, then connecting to servers with a different IP address.  Common causes of this include using a proxy or other anonymization tactic, or connecting via satellite or cellular network.

This will also happen if someone else uses your key or if you start another instance of Blockland and change your name.  Looking at the master server, this doesn't seem to be the case for you. 

There's some good discourse in this thread which seems to pin the problem on one's IP changing too frequently. so you may need to contact your ISP about it (see Pecon's reply on the 2nd page). make sure a firewall is not preventing Blockland from authenticating too.

People have run into this for years and I still don't think there's a sure fix, but Badspot has given some advice

There's some good discourse in this thread which seems to pin the problem on one's IP changing too frequently. so you may need to contact your ISP about it (see Pecon's reply on the 2nd page). make sure a firewall is not preventing Blockland from authenticating too.
The issue solved itself after about an hour, not sure what the deal was. Console log detailed something about Glass and it's prefs, but I can't exactly decrypt what it was getting at.