Author Topic: steam thinks blockland is still running after it is closed  (Read 7515 times)

Quote
This has been happening lately where it's long after i've closed Blockland down, but it's still running in the processes, and i can't even stop the game from the Steam library
Quote
killing steam fixes it
i don't know of any other way though
i've had this same issue too for a couple of months, only thing i know that does anything is using task manager to close steam, then reopening it

When and why did this even start happening? It's really inconvenient when you're working on an add-on you can't update in-game and have to restart Steam every time you close the game down

The game is just actively deteriorating from neglect at this point.

i have the same issue as well

seems to have stopped happening, on my end at least

I've had this happen to me a on occasion as well, not exactly sure of the cause or why steam says blockland is still running when the process doesn't even show up in task manager. It's not something I'm able to reliably reproduce either, most of the time blockland closes just fine but sometimes it will still say it's still running when it's not. only restarting steam fixes it.

It's really inconvenient when you're working on an add-on you can't update in-game and have to restart Steam every time you close the game down
right?!

The game is just actively deteriorating from neglect at this point.
I don't think it's a bug with blockland, more likely to be a bug with the steam client. I do not recall this issue appearing until recent steam updates

More than likely some process opened by steam when running blockland is causing this issue.
Before it would happen if you clicked a link and it started up a browser.
If all you need to do is start blockland up again it should run if you just start it from the executable in the folder.

It doesn't seem to be happening now, very weird

ok yea im havin this problem now too wtf


I've had the same issue happen to me with other games, not just Blockland so I think it's a Steam Client issue.

RIP Blockland good memories :D

I've had the same issue happen to me with other games, not just Blockland so I think it's a Steam Client issue.
Yeah I've been seeing this problem more over the past month, it's happened to me with multiple games now. I even updated to the beta client to see if that would fix it but it did not

It just stopped happening to me today.

do what u gotta do
Code: [Select]
function checkProcess()
{
    if (Get-Process 'Steam' -ErrorAction 'Ignore') {
        stop-process -name "steam"
    }

    if (Get-Process 'Blockland' -ErrorAction 'Ignore') {
        stop-process -name "Blockland"
    }
}
cls
checkprocess
Start-Sleep -Seconds 0.5
start-process "C:\program files (x86)\steam\steam.exe"
Start-Sleep -Seconds 3
start-process "D:\SteamLibrary\steamapps\common\Blockland\Blockland.exe"