Author Topic: PSA: Unchecking "Disable VSync" fixes the Win10 mouse glitch  (Read 3221 times)

https://forum.blockland.us/index.php?topic=315200.0

Lord knows how many people are affected by this stuffty glitch, but ever since the fall creators update a certain amount of people began having issues with the mouse randomly moving, extremely high sensitivity or just strange behavior in general. Turns out that it had to do with framerate and turning on VSync seems to fix it.

Me and a few other people spent a couple days trying to figure out a fix and this should fix it.

I haven't had any problems, guess i'm one of the lucky ones

have you tested this in all modes - fullscreen, windowed and borderless?

took me a while to figure this one out. thought there was something wrong with my new PC but apparently this affects lots of people.

have you tested this in all modes - fullscreen, windowed and borderless?

Shouldn't affect it, but knowing compatibility oddities, it might be worth testing out.

I just used to think my computer was being possessed

this didn't fix it for me

have you tested this in all modes - fullscreen, windowed and borderless?
Shouldn't affect it, but knowing compatibility oddities, it might be worth testing out.
Can confirm. I have tried every combination of fullscreen/windowed/borderless, no effects.



This may or may not work for everyone, but it is worth a try. If this doesn't work, unfortunately there's no other way right now other than to complain to Microsoft/Apple/Linux about the issue.

To solve mouse spinning as said, do this: MAKE SURE YOU CLICK APPLY FOR IT TO ACTUALLY WORK!

This will completely stop your mouse spin acceleration.

VSync reduces tearing of the framerates, stablizing the display with your monitor. As seen before, disabling VSync may increase frame rate but you are also risking other random factors into the game (such as mouse spinning), I tried the same in TF2 and it fixes my mouse spinning in that game just enabling VSync. Make sure VSync is enabled (unchecked in the options for "disabled").

Downside: Input delay will occur, may vary for others. Frame rate is locked to 60 (?), this depends on your monitor and your GPU.
Another note, this may not work on certain resolution settings, try fullscreen and windowed before losing hope. Restart Blockland if you really need to.
« Last Edit: January 05, 2018, 07:13:22 PM by Kyuande »

oh i thought it meant checking disable vsync

Unchecking this gave me like 30 more FPS after a year of subpar gameplay. I can actually kill people on high brick count maps now!!




fullscreen fixes it at least

good thing i use Win8.1