Author Topic: 2012/09/08 - Blockland r1730  (Read 40505 times)

I'm really happy you fixed shaders.
I'm not happy about the lag they caused.

Badspot

  • Administrator
Well, seems to be working better, but I still have odd shadows...

On max
https://56bwoa.blu.livefilestore.com/y1pSwU1_Lh8hQf_5qkdNQE0cVfQ3hMQsdl3wyExScBPyqmGCM_lXj1rO43O978M3D1nX-O5dEUZTOpFo0OgEoliVZsegqj_3REz/Blockland_00021.png?psid=1

Console.Log
http://sdrv.ms/QbwSPS

Thanks for working so hard on these, Badspot!
Also, is there any way I can get fullscreen to work?

This is some kind of macintosh only error.  I don't have a mac capable of running shaders right now so I have no means to debug this in the short term.


This is on low.
In console I get
Code: [Select]

Checking for shader shadow support:
   - Enabled via $Shader::Enabled? YES
   - ARB_shader_objects?           YES
   - ARB_shading_language_100?     YES
   - EXT_texture_array?            YES
   - EXT_texture3D?                NO
   - glTexImage3D?                 YES
   - EXT_framebuffer_object?       YES
   - ARB_shadow?                   YES
   - OpenGL Version?               2.1 NVIDIA-1.6.36
   - GLSL Language Version?        1.20
   o Shaders are                   ACTIVE

/Users/erichartman/dev/Blockland/premake/BlocklandGame/../../engine/bricks/octShadows.cpp:176 - GL Error: 1281 - GL_INVALID_VALUE
Regenerating Shadow Map FBOs...
Creating shader program from shaders/renderCsm_vert.glsl and shaders/renderCsm_frag.glsl...
Creating GLSL program...
Attaching shaders...
Linking GLSL program...
Time: []

This is some kind of macintosh only error.  I don't have a mac capable of running shaders right now so I have no means to debug this in the short term.

well why dont you get some people who have macs to test for you?

Transparent bricks now only display (mostly) properly when viewed from one side.

Transparent bricks now only display (mostly) properly when viewed from one side.
I've been having this problem too, except it also happens with non-transparent bricks.

i know someone who has a mac and can now run shaders fine.

Shaders & Shadows still won't show, however the console prints different stuff than before.

Here's my console.log of me switching from low to minimum to low. Then back.

If it helps you at all.

Still can see anything low and higher.

Shaders & Shadows still won't show, however the console prints different stuff than before.
Does it work on Minimum?

Edit: Just realized this is my 2000th post. Congratulations to me. :cookieMonster:
« Last Edit: September 09, 2012, 01:00:36 PM by dargereldren »

  • Fixed \dev\Blockland\trunk\engine\bricks\octShadows.cpp:679 - GL Error: 1280 - GL_INVALID_ENUM error spam

Yay, I can normally post my console.log again. Thanks.

Lighting now shows up!

Thanks you Badspot! Excellent work as always.

I like the Shaders but i like the way it is now :D

Sorry if anyones posted this issue yet.

With any shaders turned on the Pong projectile don't glow.

Shaders off:

Shaders on:

Still no intel support...
:c
Looks like I have to wait atleast another month.