Author Topic: 2012/09/08 - Blockland r1730  (Read 40503 times)

Yeah, minimum works for me too, although I don't see shadows

Shadows don't show up till low.

Badspot, may you fix the "Download Sounds" issue? After I download sounds from a server I still cannot hear them. I am required to restart the game and join the server again. It would be nice if you could fix this to how Downloading Music works.

I don't know why I can't see shadows, but here's another console.log, with some tracing.

could i possibly need to install new drivers?

http://www.mediafire.com/?3br148ullhbbach

happy birthday badspot
keep the updates comin :D

Yeah, minimum works for me too, although I don't see shadows
Shadows don't show up till low.

Quote from: 2012/08/09 - Shader Update Released
Minimum - You get per-pixel lighting, fog, specular hilights, and shadow coloring (the dark side of objects can be colored differently than the light side) but no shadows.

dafuc y u no read
« Last Edit: September 09, 2012, 06:46:01 PM by Christopher P. »




okay I'll try out shaders soon.

last update they no worky for me.

If you put the number only "1" for D/N cycle, even if you are actually trying to do a number 10-19, BL crashes (Freezes).

In the new update, my particals dont work right :(

This is a example...
The Second picture is me jeting in the air, not jet partical...
« Last Edit: September 10, 2012, 01:07:13 PM by Some Assembly Required »

And you guys were complaining about the launcher. Do you know how annoyed you'd be to have to redownload blockland every time he did one of these changes. Now he actually gets to get stuff done at a rate that keeps people satisfied.

Well, this is the first revision where Blockland decides to crash in the first second it opens.
Code: [Select]
//-------------------------- 9/10/2012 -- 10:34:30 -----
System & Processor Information:
  Mac OS X 10.8.1
  4.0 GB RAM
  2.5 GHz unknown Mac model (4 cores)
    x86 Architecture
    MMX detected
    SSE detected
 
Math Init:
   Installing Standard C extensions
   Installing Assembly extensions
   Installing SSE extensions
 
Input Init:

Video Init:
   Accelerated OpenGL display device detected.

Blockland v21m build 1730
Module Directory: /Users/-/Documents/Blockland
Profile Path: /Users/-/Documents/Blockland
Total Ram: 4096 MB
OS: OSX 10.8.1 r199506

--------- Parsing Arguments ---------
argc = 3
argv[2] =
Parsing command line arguments:
Error opening zip (Add-Ons/GameMode_Ninja_Jump_#A0E241.zip), need to handle this better...
--------- Loading Common ---------
Error opening zip (Add-Ons/GameMode_Ninja_Jump_#A0E241.zip), need to handle this better...
Loading compiled script base/main.cs.
Loading compiled script base/client/defaults.cs.
Loading compiled script base/server/defaults.cs.
Executing config/client/prefs.cs.
Executing config/server/prefs.cs.
Executing config/server/ADD_ON_LIST.cs.
Loading compiled script base/server/defaultMusicList.cs.
--------- Loading MODS ---------


--------- Initializing Base ---------
Loading compiled script base/client/init.cs.
Loading compiled script base/server/init.cs.
Loading compiled script base/client/canvas.cs.
Loading compiled script base/client/audio.cs.

--------- Initializing Base: Server ---------------------
Loading compiled script base/server/mainServer.cs.
Loading compiled script base/server/scripts/game.cs.

--------- Initializing Base: Client ---------------------
Loading compiled script base/client/message.cs.
Loading compiled script base/client/mission.cs.
Loading compiled script base/client/missionDownload.cs.
Loading compiled script base/client/actionMap.cs.
Activating the OpenGL display device...
Activating the OpenGL display device...
Cleaning up the display device...
>> Attempting to change display settings to windowed 1024x768x32@60Hz...
Created new window for GL [1024 x 768].
  port = 13908832
Successfully set up AGL windowed support [1024 x 768]
  doesn't need to ressurect
  saved prefs
OpenGL driver information:
  Vendor: ATI Technologies Inc.
  Renderer: ATI Radeon HD 6630M OpenGL Engine
  Version: 2.1 ATI-1.0.25
OpenGL Init: Enabled Extensions
  ARB_multitexture (Max Texture Units: 8)
  EXT_compiled_vertex_array
  EXT_texture_env_combine
  EXT_packed_pixels
  EXT_fog_coord
  ARB_texture_compression
  EXT_texture_compression_s3tc
  (ARB|EXT)_texture_env_add
  EXT_texture_filter_anisotropic (Max anisotropy: 16.000000)
  WGL_EXT_swap_control
  ATI_FSAA
  GL_ARB_vertex_buffer_object
  ARB_occlusion_query
OpenGL Init: Disabled Extensions
  EXT_paletted_texture
  NV_vertex_array_range
  3DFX_texture_compression_FXT1

  Video::setDevice - activate call done
  Video::setDevice - resetting canvas
Resetting Canvas...

OpenAL Driver Init:
OpenAL
   Vendor: Any
   Version: OpenAL 1.2
   Renderer: Software
   Extensions:

Loading compiled script base/client/scripts/allClientScripts.cs.
« Last Edit: September 10, 2012, 12:29:47 PM by BlockoCrafter »

What sort of addons did you have installed.