Author Topic: Blockland Glass 4.2  (Read 189298 times)

Not sure if anyone noticed yet but in the "My Add-Ons" tab all the add-ons that start with "Client_" are not listed. I don't know if this is intentional or not?

Only add-ons that have a server.cs file are displayed as the page was (originally) intended to be used to enable/disable add-ons, and you can't do that with client add-ons.

Glass host Cpanel messing up. Stuck on launch and when I kill it it says crashed. Server won't start, console won't respond, can't upload addons. Haven't tried FTP yet

help plz

Glass host Cpanel messing up. Stuck on launch and when I kill it it says crashed. Server won't start, console won't respond, can't upload addons. Haven't tried FTP yet

help plz
If you haven't, open a support ticket on the website. Jincux only checks this thread so often, a ticket is actually guaranteed to get their attention.



Can this not be a thing? I get it oRBs is bad. But I don't want to see this everytime I host my server. I don't even have oRBs installed, what I host my server with has a fresh install of Blockland and I never installed oRBs on it just glass.

If this message pops up for an addon that just has the prefs for oRBs then that's dumb, cause how are we suppose to prevent this message from popping up without having to go in and edit every single addon that causes this?
« Last Edit: December 20, 2017, 11:46:26 PM by RallyBlock »

Blockland Glass is bad and you should not be using it.

At first I was joking, but any add-on that spams your console because the creator doesn't like a certain add-on probably isn't that great
« Last Edit: December 21, 2017, 08:42:22 AM by Electrk.. »

Blockland is bad and you should not be using it.

is bad and you should not be using it.

bad and you should not be using it.


If this message pops up for an addon that just has the prefs for oRBs then that's dumb, cause how are we suppose to prevent this message from popping up without having to go in and edit every single addon that causes this?
you should not be using it

comment out line 99 in /resources/Support_Preferences/server/compatibility.cs to remove the orbs warning
i also saw code in /client/GlassCompatibility that appears to make a notice telling the user orbs is bad if it is detected, and it offers to delete orbs for the user if they choose to
« Last Edit: December 21, 2017, 10:35:02 AM by Mr Queeba »

Blockland Glass is bad and you should not be using it.

At first I was joking, but any add-on that spams your console because the creator doesn't like a certain add-on probably isn't that great
seriously, how petty

We included a message about compatibility issues because there are, indeed, compatibility issues. Weíve gone out of our way to very carefully ensure Glass functions well with RTB since there are several variants still around that have patches allowing it to still work.

oRBsí approach is incredibly invasive and really not a good way to go about it. Instead of offering compatibility, all your add-ons are overwritten and their code changed? Thatís not the right way to implement backwards compatibility and isnít good for either developers or users.

Only a small percentage of users actually have oRBs (thereís maybe 5 online at any given time?) and we deemed it no longer worth our time to provide support that nearly mirrors RTB for an inferior product thatís both broken and very rarely utilized.

You get the oRBs compatibility message every time an unsupported method is called thatís going to cause some sort of conflict. Our preference manager doesnít sync up with oRBsí preferences, so every time a pref is registered through oRBs you receive that message. Making the message only appear once is ineffective for debugging or trying to figure out why your pref is only showing up in one or the other manager but not both.

Thereís nothing about pettiness or personal preference here. I donít lose sleep over ďcompetitionĒ. oRBs and Glass just donít play well together and itís not a significant enough issue for us to invest a lot of time in to addressing.

You shouldn't be spamming the user's console just because they happen to be using add-ons that use oRBs.  No one codes add-ons for oRBs anymore, so the only people you're lecturing are your users, who don't even use it.