Author Topic: Blockland Glass 4.2  (Read 215737 times)

It looks like pre-loader didn't install correctly. Make sure config/main.cs is writable, and if it isn't, copy Add-Ons/System_BlocklandGlass/support/preloader.cs to config/main.cs
not sure if this helps you fix this but i just downloaded it today and put it on a pretty much fresh install of blockland. Restarting Blockland seems to have fixed it.

not sure if this helps you fix this but i just downloaded it today and put it on a pretty much fresh install of blockland. Restarting Blockland seems to have fixed it.

That'd make sense, preloader can only be installed after your first run.

hmmmmmmmm

For what it's worth, this update was supposed to come out way before the Windows update.


How do I remove the annoying "update your RTB addons" every 5 loving minutes?

yeah I really dislike the auto updates, you guys should make an option for disabling it.

why does glass constantly reconnect itself? im considering uninstalling it becuase it occasionally freezes my game for some reason and when i disconnect it which does fix the freezing it then reconnects shortly after?
plus why does it keep making noises when people leave and join the IRC? ive specifically turned off notifications for that yet it keeps making annoying noises
« Last Edit: January 13, 2018, 11:44:32 AM by K3k0m@n »

How do I remove the annoying "update your RTB addons" every 5 loving minutes?
why the forget does glass constantly reconnect itself? im considering uninstalling it becuase it occasionally freezes my game for some forgetin reason and when i disconnect it which does fix the freezing it then reconnects shortly after?? why??
plus why the forget does it keep making noises when people leave and join the IRC? ive specifically turned off notifications for that yet it keeps making annoying noises

I'm just curious, why are you both so angry? Are you trying to emphasize the importance of your bugs? We spent months working on this update and have a pretty involved beta program to try to weed out problems, do you think we threw these things in intentionally just to ruin your day? We generally panic at the first signs of bugs, these aren't things we've been aware of before you letting us know that we've just ignored and let sit around.

I've heard the first issue and its' already been addressed. The second is entirely news to me, and you've also provided absolutely nothing useful for me to track the issue with. If I were able to replicate the issue by someone else merely saying "it's broken", then it wouldn't be broken. It'll continue to be an issue until anyone provides any useful information about it.

We really don't enjoy making people upset and releasing broken thing, contrary to popular opinion. I would love to spend my afternoon behind my desk tracking down and fixing your problems, but when "why the forget" is your main use of language I really can't do that.
« Last Edit: January 13, 2018, 11:32:44 AM by Scout31 »

Honestly Stick Man just asked a question, and you didn't answer him directly, sure it's been addressed, but saying "that's already been addressed" never helps anyone. K3k wasn't really being helpful I agree there.

You're right, I should've been clearer. The one-line addition to make the import only occur when the game starts was committed yesterday to the development branch, which is always available on GitHub. It'll be included in the 4.2.1 update which is scheduled to release today or tomorrow, barring the discovery of any other major bugs causing us to delay the patch.

I've highlighted the information for easier reading.

it keep making noises when people leave and join the IRC [...] ive specifically turned off notifications for that yet it keeps making [...] noises
I checked and apparently there is no way to disable it, but I guess that if you decrease its volume to lowest it could solve your issue for now.

I'm just curious, why are you both so angry?We really don't enjoy making people upset and releasing broken thing, contrary to popular opinion. I would love to spend my afternoon behind my desk tracking down and fixing your problems, but when "why the forget" is your main use of language I really can't do that.
K3k wasn't really being helpful I agree there.
sorry i was fustrated at the time - edited my post to be less Grumpy

The second is entirely news to me, and you've also provided absolutely nothing useful for me to track the issue with. If I were able to replicate the issue by someone else merely saying "it's broken", then it wouldn't be broken. It'll continue to be an issue until anyone provides any useful information about it.
which issue is 'the second'? if its one ive stated, what would you like me to do to try and help solve the issue?

Great update, and fantastic looking OP! (Nice job JamJar)

which issue is 'the second'? if its one ive stated, what would you like me to do to try and help solve the issue?

What causes the issue? How can I cause it? How frequently? Are there any messages in your console that correspond to the reconnect happening? Can you send me a console.log of it happening?

I'll make sure the join/exit sounds don't occur unless notifications are enabled.

What causes the issue? How can I cause it? How frequently? Are there any messages in your console that correspond to the reconnect happening? Can you send me a console.log of it happening?

I'll make sure the join/exit sounds don't occur unless notifications are enabled.
heres a video of it: https://streamable.com/kydqw (no sound)
at the start i turn it off. near the end the game freezes for a couple seconds and then its back on again, without me touching the overlay.
the messages when it re-appears are:
Code: [Select]
Add-Ons/System_BlocklandGlass/client/submodules/live/GlassLiveConnection.cs (210): Unable to find function GlassLive::error
[Glass Log] Glass Live Authentication: FAILED
[Glass Log] Glass Auth: SUCCESS
[Glass Log] Glass Live Authentication: SUCCESS
Loading object base/data/shapes/player/m.dts
[Glass Error] Found rtbInfo.txt but no id for Client_EventsGUIPlus

heres a video of it: https://streamable.com/kydqw (no sound)
at the start i turn it off. near the end the game freezes for a couple seconds and then its back on again, without me touching the overlay.
the messages when it re-appears are:
Thank you very much, I've found the issue. We implemented timeout protection, and the timeout detection wasn't cancelling after disconnecting. After a set amount of time passed, it would see it was disconnected and not recognize that it's intentional, thus reconnecting you.

I've searched for the room join/exit sounds you referenced and I can't find in the code where they occur. Are you referring to a sound when you join/exit rooms or when others do?