Author Topic: Blockland Glass 4.2  (Read 174661 times)

Could you send a console.log to me?


There's an (outdated) tutorial here

Just upload the console.log file from your Blockland directory as an attachment.

There's an (outdated) tutorial here

Just upload the console.log file from your Blockland directory as an attachment.

Try to update, crash. Try to decline update, says the update is mandatory.





Infiniteloop + mandatory updating = uninstall :\

Oh dear.. Well that's concerning. If you still have a console.log, can you post it? What branch were you running?

Oh dear.. Well that's concerning. If you still have a console.log, can you post it? What branch were you running?
You didn't say what was wrong with mine

I haven't had time to sit down and trace the bugs themselves, but having the console log, I have everything I need when I do actually get in front of a computer.

Ever since I updated last I get these messages in the console every couple minutes.
Quote
Add-Ons/System_BlocklandGlass/client/GlassAuth.cs (54): Unable to find object: '' attempting to call function 'get'
BackTrace: ->TCPClient::onDisconnect->TCPClient::onDone->GlassAuthTCP::onDone


Add-Ons/System_BlocklandGlass/client/GlassAuth.cs (56): Unable to find object: '' attempting to call function 'get'
BackTrace: ->TCPClient::onDisconnect->TCPClient::onDone->GlassAuthTCP::onDone


Add-Ons/System_BlocklandGlass/client/GlassAuth.cs (60): Unable to find object: '' attempting to call function 'get'
BackTrace: ->TCPClient::onDisconnect->TCPClient::onDone->GlassAuthTCP::onDone


I'd really prefer that you don't overwrite the updater GUI. The updater is stable, and it needs to be.

I'd really prefer that you don't overwrite the updater GUI. The updater is stable, and it needs to be.
The updater gui is really ugly, though.

I'd really prefer that you don't overwrite the updater GUI. The updater is stable, and it needs to be.

I'll take a look at the hooks you've provided again, but last I recall, I wasn't able to actually make something functional without keeping some of the hack-ish work.

For everyone that's having problems with the updater, inserting $BLG::MM::UseUpdaterDefault = true; in the console and restarting Blockland will bypass the Glass skin of the updater and stick to Greek's. I'll investigate the problem more when I can.

EDIT: Most of the updater code is revised from your last PR, I don't think I've changed anything since then. The Updater GUI isn't be rewritten at all, just an alternate one is being pushed.
« Last Edit: October 22, 2015, 11:07:20 AM by Scout31 »

You shouldn't need to make any changes to the updater at all. If you want to display extra information, put it in the change log file or in the description field. Both can be formatted nicely with TML. That's what those are for.

I don't want the risk of a bad BLG update breaking the updater and preventing somebody from receiving any updates. Support_Updater should be independent.
« Last Edit: October 22, 2015, 11:48:54 AM by Greek2me »

I don't think any of it is being overwritten, it's purely graphical. Either way, Glass has no impact entirely if the $BLG::MM::UseUpdaterDefault is set to true.

The blockland glass test site is listed as a malicious website when I try to access it. Any reason for this?